Rumor: macOS Monterey users reported USB hub connectivity issues

Some Mac users who updated to macOS Monterey this week are having trouble getting USB hubs and other USB devices to work properly with their laptops.

In other user reports appearing online, USB hubs do not work at all. Some of the issues even relate to Apple Certified Hubs. Reddit user Flyersny81 recounts his experience:

The issues have been discussed on Reddit, Apple’s Developer Forums, and Apple’s Support Communities. Users reported that their hub’s USB 3.0 ports stopped working after updating to Monterey, although the HDMI, USB-C, and other hub ports continue to work normally.

My USB-C hub is having issues with this update. The HDMI port connected to my second screen works on the hub but none of the USB3 ports work at all. I have tried different C ports on the MacMini and different hubs (I have 4). I also replicated this issue on my MacBook Air M1 after updating to Monterey. Here is the hub that I am using. These hubs have worked perfectly in Big Sur.

In other cases, USB hubs work except for the power port. For some, it is the additional connectivity provided by the external screens that no longer works, the power delivered being particularly affected. From the Apple Developer Forums:

I got a call with Apple Support and they said to try an Apple Certified Hub. I used this one I had in my bag and both the HDMI and USB3 ports were working on it. I tried daisy chaining the Amazon hub to the Apple hub, but that didn’t work either. Support told me that many people are complaining about this issue and that it will hopefully be fixed in the next patch to be released.

PD (Power Delivery) over USB-C also stopped working on my 2018 MBP after updating to Monterey (12.0.1). I am using a Philips 346P1CRH. Everything worked perfectly with Big Sur.

I have the same problem with my MBP M1 2020 connected to an HP S340c external monitor. Power Delivery (PD) and Video-Connection do not work (but mouse and keyboard are still supported / working).

Same problem as everyone else, bought 34 ″ Philips 346P1CRH / 00 and everything worked fine on BigSur… After updating to Monterey, video and Ethernet work, but power is cut off. I am on a Macbook Air M1. : / Essentially, Monterey discontinued support for a large number of USB hubs. Some USB hubs work but some hub ports do not work, some hubs do not work at all.

For me, both USB-C and HDMI work on the hub, but my USB 3.0 port will only power devices and there doesn’t appear to be any data transfer. This problem is absolutely a Monterey bug. My devices were working fine before the upgrade, and I was able to reproduce the issue and reduce it by testing on a device that did not have Monterey installed.

Most reports are from M1-powered Mac owners, but not all. Some users have reported similar issues on Intel Macs. Based on user discussions, USB issues were reported in early beta versions of Monterey, suggesting it could be due to a legacy bug that Apple still hasn’t fixed.

Summary of the news:

  • Users using macOS Monterey have reported issues with USB hub connectivity
  • Check out all news and articles for rumors updates.
Disclaimer: If you need to update / change this article, please visit our help center. For the latest updates Follow us on googIe New


Source link

Steven L. Nielsen

Leave a Reply

Your email address will not be published. Required fields are marked *